Sunday, January 26, 2014

Printrbot Simple Kit Review And Getting Started Hints



I received a Printrbot Simple V2 (pre-2014 model) with the large motors and endstop switches for Christmas. My goal is to print parts for hobby robotics and R/C vehicles, as well as make parts for friends, and just learn about the technology.

Before you begin building your PrintrBot Simple, make sure to have some super glue and some blue Loctite on hand in addition to the required tools. You need the superglue pretty early in the process. The Loctite comes later.

Executive summary

The Printrbot Simple is an awesome value. It requires some work on your part to build, tune, and learn to operate. The instructions are good, but lacking in some key areas at the time of writing. If you want to learn how 3D printers work, and be able to make small parts in PLA plastic, it is both functional and tremendous fun. If you want a turnkey experience to just make parts, without tinkering,  it may not be for you. You can buy it preassembled and save some time, but a bit of mechanical understanding is still required to debug issues and set it up.

I love to tinker, and I enjoy learning to use new tools. I am very happy with the Simple. It's really neat to see a part slowly appear on the print bed. The design is well engineered - it's as strong as it needs to be, reasonably precise, and affordable enough that a hobbyist can get one.

Update: The 1/2 lb of filament that ships with the printer goes a surprisingly long way. It is plenty to get the machine calibrated and make a number of test parts.

Kit Assembly

The kit took me about 8 hours to assemble over two sessions, and then another 3-4 hours to test, tweak, and calibrate before my first print. The kit requires moderate mechanical skills to assemble - if you have ever built a balsa model airplane, the process is very similar. The laser cut ply parts are extremely clever in their design - they heavily interlock to make a very rigid structure. I found one hole that was cut in the wrong place - it took much longer to convince myself that I had not made an error than to actually fix the issue.

Follow the instructions carefully, compare each step to the pictures, and it's not difficult. The extruder assembly is not well documented, in my opinion, but the rest is fine. I can tell they put a lot of effort into the build document.

There are photos of the assembly process of my printer here.

Testing and Calibration

First, be aware that there are older versions of the Getting Started document that will show up very high in Google searches. They don't match the current version, and some of the settings in the control software are different. Make sure to grab the latest version from the Printrbot support page.

I found that the latest version of the control and slicing software, Repetier Host, did not run on my laptop with Win7. It failed with an OpenGL error. I stepped back one version and it works fine.

The Getting Started document is a tremendous help, but it is lacking some is in some key areas at the time of writing. I will attempt to supplement that here.

1) The current version references an older version of the Simple that did not have end stops. The process of setting the home position is very different than older versions, but they just left it out. If your Simple does have endstops, then you don't have to manually home it - but you DO need to make sure the endstops work first, and adjust the Z axis carefully before allowing Repetier Host to try to set the print head to the home position

To set the Z axis, I put a piece of paper on the print bed, run the Z axis down until the print head just touches the paper, and then adjust the 3 1/2" screw above the Z axis endstop switch until it just clicks the switch. That screw sets the Z home position - you want the switch to click when it is one paper's width above the print bed. Note that you probably want to do this with blue painter's tape on the bed, since most people print that way to make the part easier to remove.

Once that's accomplished, you can use the home button on the manual control tab to send the print head to the home position on each axis, one at a time. That minimizes the risk in case one of the switches is not hooked up correctly.

With the endstops adjusted, Repetier will automatically return to the home position at the beginning of each print.

2) The process of leveling the bed is not documented in the Getting Started document. This is a misnomer - you are not leveling the bed against gravity - you are making sure the print bed is an equal distance from the print head no matter where the print head is.

I put on blue tape, then manually moved the print head to the front left corner (home). These directions are relative to the printer facing you - the "front" of the bed is closest to you. Make sure the print head is just over the bed, so that you can slip a piece of paper between them, and encounter a small amount of resistance when you pull it out.

Then manually move the print head to each corner and check that the height is the same. If not, tighten or loosen the hex screw in that corner to remove the warp in the print bed. Repeat this for all four corners. This way, no matter where on the bed it is, the head will always be a paper thickness's height above the bed. This prevents the head from smacking the bed as it prints the first layer.

3) Loading filament is not hard to figure out, but it's not discussed much in the documentation. The assembly that the fan is attached to also houses a large ball bearing. This bearing pushes the filament up against the hob bolt. Once the extruder is up to temperature, unlock the fan assembly and pivot it towards the front of the printer. That will expose the plastic tube that the filament feeds through. Push the filament through the tube, perhaps 5 cm, until you encounter some resistance. Gentle pressure will result in a bit of filament squirting out the hot end. Rotate the fan assembly back into position and lock it - the bearing is now pressing the filament against the hobbed bolt.

4) The Getting Started guide gives excellent instructions on how to test the X, Y and Z axis, but nothing about how to test the extruder. On the manual control tab in Repetier, there are buttons to extrude and retract the filament. It may take 20-30 mm of extrusion before you get filament squirting out the print head. I put a piece of cardboard under the extruder to catch it. I found it useful to do this right before every print.

5) Very low ambient temperatures will cause the extruder and all control motors to shut down. I tried to test mine in a garage in January in Ohio. Temps below 5 degrees Celsius will trigger a MINTEMP log event, which is the controller board's way of protecting you from a broken thermistor on the print head. However, Repetier doesn't do anything but quietly log it, so it can easily convince you that your new toy is dead. :-) I brought inside to warm up and POOF, it came to life.

I have mine set up in the basement, and 195 deg C works well on my machine.

6) The current version of the Getting Started guide tells you to disable the cooling fan option in Repetier, since the Simple does not have a fan. This is no longer the case - enabling the fan with the default options worked well for me.

First prints!

After leveling the bed, testing the motors, and configuring the software, I loaded up the 5mm Calibration Cube Steps, sliced it with the default settings, crossed my fingers, and hit Run. I was expecting a mess on the first run - a glob of spaghetti vaguely distributed in the shape that I was intending to print. I figured it would take days to get it adjusted to print accurately.

I was wrong. It worked perfectly the very first time. I consider that a testament to Brook Drumm's design, and the quality of the support documentation.


It was absolutely mesmerizing.

The second print, I ran into an issue. My extruder stopped feeding. It took a while to notice - there is little visual indication when that happens. I finally figured it out by marking the filament with a dot from a Sharpie marker. It it stops moving into the extruder, it's pretty obvious, and I recommend that for your first couple prints.

A little digging showed that the filament had slipped off the roller bearing and jammed against the side of the slot. A forum post indicated that this can be caused by a loose motor mount screw, the one on the lower right if you are facing the motor shaft. I tightened that, and it got better, but still jammed after a few minutes of printing if I didn't guide the filament by hand. Another forum post pointed me at this cool filament guide and I printed it out.

It solved the problem - I have had no feed problems since. I intend to make a spool to feed the filament from for longer prints.




There is something seriously neat about using a tool to make a part to upgrade itself. It is officially my first useful print.

To confirm that the feed issue was truly fixed, I wanted to print something a bit bigger. A good friend has an ARDrone and was looking for a good camera mount for it. This 808 camera mount for the ARDrone uses rubber bands to isolate the camera on a suspended platform.


Both prints were completely uneventful. And that's awesome. It just worked. Testing the mount will need to wait until warmer weather.

So there it is. I am thrilled with it. I am working on getting better in Sketchup and learning some OpenSCAD so that I can design my own parts.

Oh yeah: if you put a square of thin carpet under the printer, it has less tendency to vibrate and move around, and is also quieter.






PrintrBot Simple Calibration Print from Jason Bowling on Vimeo.

No comments:

Post a Comment